Sunday, July 30, 2017

Office 365 –Missing Nintex Icons on the top ribbon

While working with Nintex in office 365 environment, suddenly Nintex forms and workflow icons are missing as shown the image below.



I have all the site contents, I am seeing Forms and Nintex are installed as shown below. 



I have verified all the details and permissions ( I am site collection admin). I have verified the post from Nintex community but It wasn’t worked for me.

After verifying some time I had no clue on what next. Finally I found the post from swetha s to fix the issue. I have Removed and add re-add the forms app to the site as below.



After re-installing the app, I am able to see the forms icon on the top. But we have to design the forms once again and re-publish the forms and workflows (if you have task forms customized using Nintex forms) to the site.


Good. But next question in your mind – Do I need to add the app for all the sites in the site collect?No, don’t worry, it is just for one site and no need to add all the sites. 

Saturday, July 29, 2017

SharePoint list Nintex form error – “The app Nintex Forms for Office 365 is out of date. Please update the app.”

While working with Nintex form in office 365 site I got an error saying that “The app Nintex Forms for Office 365 is out of date. Please update the app.” as shown the image below.



As I am new to Nintex forms, thought this is update news from Nintex team and tried to verify the option to update the Nintex forms by clicking on the Nintex forms in site contents. But I am unable find any update link on the app.

Going through few blog posts, I got the reason for the error. We got the error because of the script in the form. I wrote alet(‘hi’) instead alert(‘hi’). Silly right? Yes sometimes happens.

After fixing the error I am able to open the form without errors. 

Friday, June 26, 2015

SharePoint User Display issue: Display name incorrect in one site collection

Recently I got an issue in my SharePoint 2013 production environment. One of the user display name not showing properly. Instead of his name, it is showing one of the employee who left the organization. By checking the user details in AD we got the details. AD team updated two emails for one user. One is his own email and other email is one of the employee who left the company. We tracked the issue and updated the profile AD and ran User Profile Sync. Everything worked well till now.

But user still having the issue in one site, his display name not showing correctly. Instead of his name, it is showing employee who left the organization. We are seeing this issue only for one site collection. Tried different approaches like deleting user permissions in the site through UI and using PowerShell commands. Nothing worked.

After Googling the issue, we got the resolution. We are seeing that issue due caching in SharePoint site collection. When I remove and add the data in SharePoint site group, SharePoint site collection user details from all users located in <Site URL>/_layouts/people.aspx?MembershipGroupId=0


To fix the issue, we need to remove the user from all users list and read it to the list. But before that we need to check all the user permissions in the site (including all the groups and individual permissions) and need to re add all the places. 

Hope this helps.

Wednesday, June 24, 2015

Copy-SPSite: Rename/Recreate SharePoint site collection

Most of my clients had a requirement to rename SharePoint site collection in all SharePoint versions including SharePoint 200, 2010 and 2013. To do that we have to take the existing site collection backup, Delete the site collection and Restore it new site collection. If anything happens in this process, we are gone. Nothing left.

But in SharePoint 2013 we got new command, Copy-SPSite command allows us to copy the site collection. This option allows us to duplicate the site collection to new site collection. We have options to specify the destination DB.

Here is the syntax for Copy-SPSite command,

Copy-SPSite Source Site URL [-DestinationDatabase Destination DB] -TargetUrl Target Site URL

We can use this command to copy the site collection in same content DB. Copy-SPSite command will not work for copy the site collection in other content databases. To do this we have to follow backup and restore process.

We can copy host named site collections using Copy-SPSite command.

Copy-SPSite -Identity Source Host Named Site collection URL -TargetUrl Destination Host Named Site collection URL -HostHeaderWebApplication Host Header web application URL

Before that we need to run Remove-SPSiteUrl command as below.


Remove-SPSiteURL -URL Host named Site collection URL

Saturday, June 20, 2015

SharePoint 2013 error – Site stuck up in Read-only mode after interrupted backup

While working with SharePoint 2013 restore and backup I got interesting error in one of my host named site collection (I hope this is generic issue, not specific to host named site collection) saying as shown the image below.



When I try to fix this issue from SharePoint central administration quotas, all the options are disabled and unable to change anything as shown the image below.


By going through some of the blogs, I got the issue. In SharePoint 2013, we are having Manintanence Mode property for SPSite makes SharePoint site is undergoing a Maintenance & is read only. We can set this SharePoint site when content DB is in read only state, or when SharePoint site upgrade, moving SharePoint site in process.
We can fix this error by clearing ClearMaintenanceMode method in SpSiteAdministration object. We can do this by running following command,
$Site = new-object Microsoft.SharePoint.Administration.SPSiteAdministration(SITE URL)  $Site.ClearMaintenanceMode()
This fixed my issue. Hope this helps.